Iframeinterval doesn't seem to work

I am trying to see what knobs I can tune to lower the network bandwidth when using h265 lossless streaming.

In below test, I just use bunch of png files we captured to provide h265 lossless streaming.

$ test-launch 'multifilesrc location="%07d_0.png" caps="image/png,framerate=13/1" ! pngdec ! nvvidconv ! nvv4l2h265enc enable-lossless=true iframeinterval=30 ! rtph265pay name=pay0 pt=96'

I tried iframeinterval from 1 to 1000, but that doesn’t seem to make any difference on the network bandwidth usage when I watch the stream from a client on the same LAN using VLC player. Is this flag a no-op in JP 4.6.1?

BTW, I also tried h264 but found nvv4l2h264enc enable-lossless=true and nvv4l2h264enc enable-lossless=false use about same network bandwidth, so I assume the property enable-lossless is probably a no-op for h264 in JP 4.6.1. Can someone confirm?

For lossless encoding the bitrate cannot be changed. If you need to control bitrate, please set to YUV420 for video encoding.

With nvv4l2h265enc, even if setting enable-lossless to false, if I then adjust iframeinterval from 1 to 1000, it does NOT make a difference with bandwidth usage.

Please set CBR + virtual buffer size for a try. Here is an example for reference:
Random blockiness in the picture RTSP server-client -Jetson TX2 - #5 by DaneLLL

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.