Ignores breakpoints on GTX690 w VS2010

I’m trying everything I can think of to get the VS2010 debugger working with the CUDA sample code. I’ve uninstalled and re-installed everything a couple times now. It was a clean new system with a GTX 690 (two cores), the latest CUDA 5.0 SDK and Nsight Nexus 3.0. (I was having the same problem with Nsight 2.2) I’m building and running CUDA code but when I try CUDA debugging on my local machine with the monitor running locally the program ignores the breakpoints and exits. The monitor triggers so it knows that something is running but the breakpoints are just ignored.

I feel like it might be something to do with how I have the monitor configured. I’d like to think that there is a way for me to HW debug on one of my GTX 690 cores while running the display on the other. Any help appreciated.

Sounds like you need to enable GPU debug symbols (-G) flag. It should be in the CUDA options on the Visual Studio properties… not familiar with Nexus, but probably a similar option is available on it.