I'm seeing more and more often our custom board entering BOOTLOADER SHELL MODE

When this starts to happen, the device is effectively bricked.

There is not enough information in this related topic to explain what this mode is, how to prevent it (or trigger it), and what the causes might be for entering the mode.

What I have observed:

I have a board that it began to happen on, and I thought it was “broken” in this way. Reflashing the SoM does not seem to change its behavior.

Then a few weeks later I tried the board again and it worked like normal for a few boots, and went back to going into this mode again.

On another device which was working fine, it did this once, and the next boot attempt, it booted fine.

There seems to be some sort of maybe power-related behavior that triggers entering this mode.

Just want to clarify, are these on devkit or custom board?

custom carrier board with the optional reboot timing circuit as detailed by my colleague in:


Just want to clarify this again. Could you share the boot log when you enter the bootloader shell ?

Thanks for the suggestion and request. I know about the boot log, this is a serial log that I will need to connect somehow to read its output, right? I have never obtained this. I will look into how to do it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.