Image not turning hdmi up on booting


I have successfully flashed the images from my machine for my custom-board with Nvidia Xavier NX, when I zip/tar/bzip/gzip the images i.e., Linux_for_tegra and /built/image/directory for flashing emmc based board it boots fine but HDMI doesn’t turn on.

The issue I see is there’s a backlight turned on in the HDMI screen, the ttyACM0 port is giving serial console only HDMI doesn’t give the GUI experience after doing the first time system configuration.

I see that BUILD_IMG/ directory has root permissions when I compress the file the binaries for userspace apps or kernel modules for HDMI must be non-executable.
Kindly, help me with best way to compress and send images over for other PCs to flash the board.

The kernel image has nothing to do with the custom board… generally the device tree files should be configured but not image.

What do you want to do here? You want to debug the HDMI issue or just want us to provide a method to update kernel image?

I only want to know how to send binaries consisting file-system image compressed.

Just use ethernet or something else to send the file to the board should be ok.

Or just use the host pc to flash it…

Firstly, thanks for the response.
I tried to copy the binaries built :
to flash binaries from other system. This validation is being done so that anyone can flash the images from shared memory.

I resolved the error of ownership and group assigned to the directories.
By using chown and chgrp to make root user alone to access.
But I am facing same issue, flash done but no GUI on HDMI.

Is there any information on L4T which can cause this issue ??


As I said on previous comment, you need to configure the dts if this is a custom board.

The kernel image has nothing to do with the custom board… generally the device tree files should be configured.

Yes @WayneWWW I have done required changes.
As i mention :

My concern is related to flashing from other systems(Ubuntu 18.04).

If you use the original jetpack rootfs then the gdm3 shall not have problem.

Please share your dmesg to confirm this is not kernel issue.

Thanks for the support.
The L4T I used had missing packages, I cloned one from Nvidia sources and it works now.

Yash M J

1 Like