Import error when running python script


I was trying to run the script like python, but i got this error. Is anyone know how to solve this? Or how can I run the script using python?

Traceback (most recent call last):
File “”, line 1, in
File “/home/neuralimage0/.local/share/ov/pkg/audio2face-2022.2.1/exts/omni.audio2face.core/omni/audio2face/core/”, line 2, in
from .scripts.extension import *
File “/home/neuralimage0/.local/share/ov/pkg/audio2face-2022.2.1/exts/omni.audio2face.core/omni/audio2face/core/scripts/”, line 13, in
import omni.graph.core as og
File “/home/neuralimage0/.local/share/ov/pkg/audio2face-2022.2.1/kit/exts/omni.graph/omni/graph/core/”, line 17, in
from . import _omni_graph_core # noqa: F401,PLW0406
ImportError: cannot open shared object file: No such file or directory

How to I set up the environment to run?

I found this seemingly related thread, which might help ImportError: cannot import omni.replicator.core due to missing - #5 by ahaidu

In the meantime, I’ve asked our engineers and will get back to you as soon as I hear from them.

Have you tried running regular A2F app on this machine to see if it works?

Yes, it works.

Hi there,
Can you paste me the command you are using to run that script?
Thank you

I solved it! Thx! I can use headless API to achieve what I want. However, I ran the script like this:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.