ImportError: /usr/lib/aarch64-linux-gnu/ file too short

I’m trying to run tensorflow on the nvidia xaviers. I’ve got it working in docker, but on the secondary xavier with the same setup, I’m running into this as well. Has anyone run into this error, and can advise a fix, or is it better to just reflash.

Thank you.


It looks like that there are some issue in the nvdocker overlay.
In general, you should see the similar mapping log when searching for the fatbinaryloader library:

Ex. (test on 32.2.0)

$  sudo find / -iname*

If you don’t see the similar log, please reflash and reinstall the package for the device.


see docker runtime setting GitHub - dusty-nv/jetson-containers: Machine Learning Containers for NVIDIA Jetson and JetPack-L4T