Importing .sldpart and .sldasm to Isaac Sim fails and workflow question

Hi People,

We have been trying unsuccessfully to import a complex assembly from SolidWorks into Isaac Sim or Omniverse. The import simply fails with a “failed to convert -10014” error code. I have looked around and understand the OnShape is probably the best supported CAD tool for interfacing with Isaac Sim, but our mechanical work is done through SolidWorks exclusively.

Our temporary solution is to import our .step files into 3ds Max and export the model as an .fbx (step files are also not getting imported) and finally importing that into Isaac Sim. This solution is not sustainable and does not scale as we will have to re-do collisions, joints and actuations if there are any changes to the CAD model. We are trying to create a workflow which is directly coupled to SolidWorks so we do not have to do everything again.

Based on the above the question is two fold:

  • How can we import .sldasm and .sldpart into Isaac Sim directly? We are using SolidWorks 2024 and are using the CADimporter extension
  • Is there a workflow which tightly couples SolidWorks and Isaac Sim together?

Edit: I got the same error after creating a simple 2-part assembly and importing it to Isaac Sim.

Thanks in advance

@scn i am just another user passing by, and i have a few inquiries (which may or may not be related to your questions):

  1. which OV apps have you tried besides Isaac Sim? and what are the versions used?
  2. is it safe to assume the issue you are having with Isaac Sim, is with the latest public release of Isaac Sim (version 2022.2.1)?
  3. when you mentioned that STEP files do not get imported via the CAD importer, does it happen to any STEP files?
  4. maybe you could provide the mods/devs with more info by uploading the latest logs (Isaac-Sim and/or Isaac-Sim_App_Selector) in its entirety in case they can help pinpoint the issue related to the 10004 conversion failure report?
1 Like

Hi @Simplychenable thanks for passing by and taking the time to try and help!

  1. Omniverse Create 2023.2.0.
  2. Yes, that is the version I am using. Not sure we got to test it with the previous version.
  3. That is a good question since we have been able to import STEPs downloaded online. But STEPs exported from SolidWorks 2023 we are not able to import.
  4. Good suggestion, the outputs I see are below. I am not sure how to locate the latest logs from Isaac Sim. I hope this is enough, otherwise I need a little help locating these.

Inside the Isaac Sim console:

[Info] [omni.kit.converter.cad.omni_client_wrapper] Creating dir C:/Users/omniverse-02/Desktop/convertedAssets/Main ASM_081951...
[Info] [omni.kit.converter.cad.cad_converter_delegate] IMPORT FAILED

In the Windows Command Prompt

Wed Oct 11 08:19:51 2023
Wed Oct 11 08:19:52 2023
    BEGIN OpenFile
Wed Oct 11 08:19:52 2023
    BEGIN Import
<Error number="-10014"/>

you should be able to find all Isaac Sim related logs in the following directories here (under the corresponding version folder):

  • C:\Users\%username%\.nvidia-omniverse\logs\Kit\Isaac-Sim
  • C:\Users\%username%\.nvidia-omniverse\logs\Kit\Isaac-Sim_App_Selector

but from the look of it, there isn’t much else besides the ‘import failed’ report.

There was nothing of use in there unfortunately. Is it possible for an NVIDIA rep to take a look at this?

I don’t know if there is a policy on bumping topics. Let me know if this is not OK.

Still looking for any help on this.

Hi @scn - I have forwarded your question to right forum section. where hopefully you will get an answer.

That’s great to hear. Let’s make sure to keep the post alive as long as necessary 🙌 looking forward to hearing from the team.