Impossible install drivers

Hi,
I have integrated Intel and nvidia GeForce940MX and it’s impossible to install drivers for it.
I got:
ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0 ==
modalias : pci:v000010DEd0000134Dsv000017AAsd000039CEbc03sc02i00
vendor : NVIDIA Corporation
model : GM108M [GeForce 940MX]
driver : nvidia-driver-415 - third-party free
driver : nvidia-driver-440-server - distro non-free
driver : nvidia-driver-455 - third-party free recommended
driver : nvidia-driver-418-server - distro non-free
driver : nvidia-driver-410 - third-party free
driver : nvidia-driver-450-server - distro non-free
driver : nvidia-driver-450 - distro non-free
driver : nvidia-driver-390 - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin
So i ran autoinstall and I got the driver and the message about Secure Boot, agreed and did reboot ("note that I didn’t have to write in a password after reboot, although the message told me that we’ll be necessary).
So after reboot and everything I ran ubuntu-drivers devices again and again got the same message like on the beginning, that the geforce needs the drivers. So I run sudo apt install nvidia-driver-455 and got “nvidia-driver-455 is already the newest version”.
So I checked if the card is visible and ran cat /proc/asound/cards:
cat cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xa4320000 irq 139
But it shows only integrated Intel card.
When I run nvidia-settings I have an option to set prime card and I can choose between Intel and Nvidia. So I chose nvidia. However on the console the is message:
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

I also ran prime-select nvidia and it tells me that “Info: the nvidia profile is already set”, although the system doesn’t see the nvidia card! Also, when I run nvidia-smi it shows:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
ubuntu-drivers list gives:
nvidia-driver-410
nvidia-driver-455
nvidia-driver-450
nvidia-driver-450-server
nvidia-driver-415
nvidia-driver-440-server
nvidia-driver-418-server
nvidia-driver-390

I have no idea what is going on. The Ubuntu is 18.04.
Thanks in advance

Some mainboards have a bug so the key import for secure boot doesn’t work. Please try disabling secure boot in bios.