Imx327 camera on TX2

Hi,
I use an IMX327 camera on the TX2 DevKit,The camera adapter used directly leads the camera interface pin out, without the PCA95X module.
I measured the camera interface and found that there was no 1.2V output, but has 1.8V and 2.8V .
Is the problem shown in log caused by the absence of 1.2V?
imx327-log.txt (67.7 KB)

[ 11.596544] tegra-i2c 3180000.i2c: pio timed out addr: 0x10 tlen:12 rlen:4
[ 11.603486] tegra-i2c 3180000.i2c: — register dump for debugging ----
[ 11.610171] tegra-i2c 3180000.i2c: I2C_CNFG - 0x22c00
[ 11.615266] tegra-i2c 3180000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[ 11.621927] tegra-i2c 3180000.i2c: I2C_FIFO_CONTROL - 0xe0
[ 11.627458] tegra-i2c 3180000.i2c: I2C_FIFO_STATUS - 0x800080
[ 11.633247] tegra-i2c 3180000.i2c: I2C_INT_MASK - 0x7d
[ 11.638423] tegra-i2c 3180000.i2c: I2C_INT_STATUS - 0x2
[ 11.643692] tegra-i2c 3180000.i2c: i2c transfer timed out addr: 0x10
[ 1.422503] imx327 2-001a: imx_probe: Probing v4l2 sensor at addr 0x1a - Aug 29 2022/08:46:28
[ 1.422519] imx327 2-001a: imx_probe: of_match_device() OK
[ 1.422574] imx327 2-001a: imx_probe: devm_kzalloc() OK
[ 1.424108] imx327 2-001a: imx_parse_dt: external-trigger-mode not present in DT, def=-1
[ 1.424133] imx327 2-001a: imx_parse_dt: flash-output=1
[ 1.424140] imx327 2-001a: imx_parse_dt: fpga_addr not present in DT, def=0x10
[ 1.426343] imx327 2-001a: imx_power_get: Get regulator avdd
[ 1.427564] imx327 2-001a: imx_power_get: Get regulator iovdd
[ 1.428015] imx327 2-001a: imx_power_get: Get regulator dvdd
[ 1.430726] imx327 2-001a: tegracam sensor driver:vc_mipi_v2.0.6
[ 1.430736] imx327 2-001a: imx_probe: tegracam_device_register() OK
[ 1.430761] imx327 2-001a: imx_board_setup: mclk_freq=24000 pixel_clock=801907200 cil_settletime=0 discontinuous_clk=0
[ 1.430771] imx327 2-001a: imx_board_setup: width,height,line_length=1920,1080,2200 pix_fmt=0x30314752 ‘RG10’ embedded_metadata_height=1

It’s depend on HW design. You may need to confirm with HW to confirm if need 1.2V or not.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.