in Deepstream 4.0.1, How to use Secondary gie-0 without tracker?

I ran secondary-gie0 without tracker but i failed to run
so, How to run secondary-gie0 without a tracker?

ps. in config_infer_secondary_vehicletypes.txt, what is the net-scale-factor?

Hi,

You can disable the tracker component in the config file directly.

source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

[tracker]
<b>enable=0</b>
tracker-width=640
tracker-height=368
#ll-lib-file=/opt/nvidia/deepstream/deepstream-4.0/lib/libnvds_mot_iou.so
#ll-lib-file=/opt/nvidia/deepstream/deepstream-4.0/lib/libnvds_nvdcf.so
ll-lib-file=/opt/nvidia/deepstream/deepstream-4.0/lib/libnvds_mot_klt.so
#ll-config-file required for DCF/IOU only
#ll-config-file=tracker_config.yml
#ll-config-file=iou_config.txt
gpu-id=0
#enable-batch-process applicable to DCF only
enable-batch-process=1
...

Thanks.

Secondary gie-0 does not work after changing tracker enable to 0

Hi,

Sorry for the missing.
Please also turn off the async mode in the secondary model.

Ex. config_infer_secondary_carcolor.txt

[property]
gpu-id=0
...
<b>classifier-async-mode=0</b>

Thanks.

Thanks for the quick reply!!

Your answer was helpful.

one more question.

I retrained secondary gie but the results are different from when I tested it on my computer.

I think the net-scale-factor is the cause, but I don’t know exactly what it is.

what is the net-scale-factor?

Hi,

This is a scaling factor of input image that similar to the power layer on the top of model.

In some use case, they prefer to adjust image range from [0, 255] into [-1, 1].
So we provide net-scale-factor and offsets which can be combined into TensorRT pre-process stage.

You can set the net-scale-factor=1 if you don’t need this feature.

Thanks.