In Deepstream config file uri='RTSP URI'

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU 3070
• DeepStream Version 5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only) 525
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

my rtsp uri = rtsp://user:1234@

i try gst-launch-1.0 rtspsrc location=rtsp://user:1234@ ! fakesink

Progress: (connect) Connecting to rtsp://user:1234@
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not open resource for reading.
Additional debug info:
gstrtspsrc.c(5829): gst_rtspsrc_setup_auth (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
No supported authentication protocol was found

but gst-launch-1.0 rtspsrc location=‘rtsp://user:1234@ ! fakesink’ is no problem

so i want put ‘rtsp uri’ in deepstream config file

what should i do?

You should input the uri without any quotation mark in the configuration file.

then throw out invalid rtspsrc error