In VPI, CPU backend and CUDA backend have different result

I tried to use VPI samples in JetPack 4.3.0.
Then, I found that CPU backend and CUDA backend have different result.

I read the document of VPI. But, I didn’t know whether it’s a limitation of VPI.
I removed “vpiSubmitGaussianImageFilter” from this pipeline.
As a result, CPU backend and CUDA backend results match.


Thanks for your question.
Let me check this with our internal team and update more information with you later.


We got the response from our internal team:

Please noticed that VPI doesn’t claim that the different backends(CPU, CUDA, PVA) return exactly the same result.
The maximum absolute difference between resample is 2, which isn’t noticeable to the naked eye.

We strive to get all backends to return the same output for a given algorithm and input.
But sometimes some sacrifices must be made to take advantage of some optimization opportunities that might affect the result by a tiny bit.



Thank you for your explanation. I understood reason.
If you possible, I hope you add the description of this behavior to VPI document.

Because, current VPI document does not mention about this behavior.
So, current document misleads about this behavior.


YES. We will add this information to the document.
Thanks for the suggestion.