Inconsistent Behavior When Starting X in CentOS 7

I have a Lenovo ThinkStation D20 and 2ea Quadro 400 graphics cards installed. It’s running CentOS 7 and has been updated to the latest kernel offered by the official repositories.

Everything is showing up properly–that is, the system identifies the two graphics cards–but I’m experiencing a number of very strange issues:

– X will only load when Gnome is set as the GUI. Typically I use XFCE and it won’t load at all.
– When Gnome is set as the GUI, I can access it once and all subsequent attempts to start the GUI fail. In other words, if I terminate the X session but don’t log out of the computer, the next time X is started it will hang. (The green NVIDIA logo appears on the screen but it never loads the desktop. Note that this logo does not appear on the first successful start of Gnome.)
– If I execute the nvidia-settings command in a working Gnome session, both video cards are active and I can enable all of my monitors and configure them how I want.
– This same behavior persists even when only one graphics card is installed in the system.

I have tried the official NVIDIA driver package plus the driver package in the unofficial repository. The behavior is the same.

Here is the output of nvidia-bug-report.sh from the first successful start of Gnome:
http://unwisdom.org/temp/nvidia-bug-report.log.gz-01

Second unsuccessful start of Gnome during the same logon session (screen hangs at NVIDIA logo):
http://unwisdom.org/temp/nvidia-bug-report.log.gz-02

Graphics card info reported by nvidia-settings in a successful Gnome session:
http://unwisdom.org/temp/nvidia-01.png
http://unwisdom.org/temp/nvidia-02.png

From the second bug report (after screen hangs on NVIDIA logo):

xset -q:
xset: unable to open display “”


nvidia-settings -q all:
ERROR: Cannot open display ‘:0’.


xrandr --verbose:
Can’t open display :0

These are the only problems I am able to find. The same errors are present when the system successfully loads Gnome.

This time the packaged drivers were installed from elrepo.

Maybe the current CentOS 7 kernel is no longer compatible with the 340.xx drivers? Is anyone out there using the 340.xx drivers successfully with the latest version of CentOS?

Kernel version is 3.10.0-957.10.1.

Does this still happen if you remove “rhgb quiet” from kernel command-line?

The current elrepo package for the 340 driver series works fine with CentOS 7.6. But you are expected to install it on a clean system, not one that was messed up by previous non rpm driver installations and is contaminated with their leftovers.

Holy hell… the official releases really leave that much cruft around?

I reinstalled CentOS 7, avoided the official NVIDIA driver download and went straight to the epel package–now I can get into XFCE along with Gnome. So that’s a small amount of progress.

But overall, behavior is the same: the first X session works fine, but there are always problems when I shutdown X and then restart it. Sometimes X loads, but the environment is very unstable (one monitor is out and then X eventually crashes into an unrecoverable state). Other times it just stalls on the green NVIDIA logo.

Removing “rhgb quiet” only affected the boot process, not how X is started.

Well, I wasn’t able to get anywhere with the Quadro 400 cards so they’re out. I tried installing a quad-head NVS510 and used the drivers from the epel repository–all is working fine.