Incorrect monitor resolution after installation of nvidia-current package via synaptic running Linux

Hello –

I tried to make my topic title as descriptive as possible.

My set up is as follows:

One monitor at resolution 1920x1080 - works fine, not part of the problem.
A second monitor at good resolution 1360x768, however after installing nvidia-current from the synaptic package manager (also happens when downloading and installing from the official .run files) it makes me use 1024x768 and otherwise my monitor sends me, “Unsupported Signal”.

For now, I’ve had to uninstall the proprietary drivers and continue using the widely distributed Nouveau, however, I’d like to use Compiz and add some shabang to my awesome computer.

Any help is widely appreciated.

INFO

(this is my website)

http://majornoob.com/downloads/nvidia-support/nvidia-bug-report.log.gz

Card: GeForce GTX 550 Ti (1)

Hello??

Hello,

This place is a graveyard. You are like to win the lottery three times in a row before official help is given, I daresay. (joke)

This is what I did to fix the problem; a manual install. It might not work for you, but I hope it does. Also, don’t do this if you are uncomfortable with it.

  1. remove nvidia drivers (purge them) and make sure only nvidia-common exists. Make sure you de-activated them before you uninstall them, done through Additional Drivers or through Additional Drivers within the Software Center. (please tell us your distro and other specs) After they are de-activated, reboot the computer and then purge nvidia (all BUT nvidia-common).

These are the commands I ran;

sudo apt-get purge nvidia-current (Change “nvidia-current” to the driver you have installed)
sudo apt-get update
sudo rm /etc/X11/xorg.conf (make a backup first!)
sudo apt-get update

When you first run “sudo rm” it should not display any text. That means it was removed properly. Run the command again and if you are presented with text that says “file does not exist”, it is gone and you ran it right. But this is ONLY if the first time running the code resulted in no errors or text.

Reboot again now. Next we will run some more commands;

  1. install these packages: sudo apt-get install linux-source && sudo apt-get install linux-headers-3.5.0-17-generic

If it says the files are already installed, skip to step 3. If they aren’t and you get errors, try running as sudo -i.

  1. Download the PROPER driver and BIT type. If you don’t you will encounter errors that may result in having to re-install Ubuntu/Linux. Save this file to HOME and rename the file something short, like “NVIDIA”. Remember, sensitivity is important! Write this name down someplace and the location of the file. This will include the file extensions, too. Right click the file, go to Properties, then Permissions and check “Allow executable”. Close the tab.

Before we continue, update again with “sudo apt-get update”. Reboot. Log in again and enter the CLI by pressing CTRL+ALT F1 and make sure you are in TTY1. Log in with your login details. If you still get a “out of range” problem, press “auto detect” on your monitor if you have it. If that doesn’t work, press CTRL+ALT F7 to get back into the computer and following step 4 to step 6. If you don’t have this problem, skip to step 6.

  1. Open the terminal and type the following commands;

sudo apt-get install v86d
sudo apt-get hwinfo
sudo hwinfo --framebuffer

The last command should present you with an output similar to “???x???-24” where the “???” is your BEST supported monitor size and the “-24” is also different depending on your monitor. Copy this down. If yours doesn’t display, just get your monitor size and leave the -24 there. Otherwise, you can try the command “sudo lshw”.

Now you should have something like this: “uvesafb mode_option=1280x800-24 mtrr=3 scroll=ywrap” where the bolded part is the text you edit to fit your monitor/output.

Now open the terminal and type;

sudo nano /etc/initramfs-tools/modules file

It should bring up a file to edit within the terminal. Go ALL the way down to the bottom of the file and add the above line to the end of the file, like so:

uvesafb mode_option=1280x800-24 mtrr=3 scroll=ywrap

Hit CTRL+O to save the file. It will ask if you want to save over the old one. Press enter. Now it is saved. Not press CTRL+X to exit out of the file and back to the terminal. Now exit out of the terminal.

  1. Now we need to rebuild/update the GRUB. Open the terminal again and type;

sudo update-initramfs -u
sudo update-grub

Now exit terminal. Reboot computer. Your tty should be visible again and the signal out of range should either be gone or fixable by either pressing “auto detect” on your monitor or turning the monitor off and off again.

  1. Now that we are in the CLI, Command Line Interface, we need to log in with our details. Once we are logged in, we need to stop X Server. I am going to assume you are in Ubuntu 12.04 LTS. Otherwise, you will need to switch out “lightdm” with your distro’s version.

sudo service lightdm stop

This should say the it is “waiting/stopping”

Change the directory to where the NVIDIA driver you downloaded is at. If you placed it at home, the command should be;

cd /home/USER/

if you placed it at the desktop, it should be;

cd /home/USER/Desktop

  1. Now we need to execute the .run file. Remember how I said rename the file and keep the EXACT and FULL name written down someplace? Get the name, we need it. For this example, I will be using “nvidia-304.64”.

sudo sh nvidia-304.64.run

This will start an installation progress bar that will ultimately lead you to a screen of instructions. If it asks you if you want it, the installer, to do some things for you, say yes. But if it mentions the X Server/org still running or that Nouveau isn’t disable, you will have to get back into the computer and first take care of those problems. However, I’m pretty sure you should not encounter them. Make sure you update your xorg.profile if it asks to do it.

If there is a driver already installed and you get “There appears to be a driver already installed”, then just let it uninstall it and reinstall its own driver.

Once you say “yes” to what the installer wants, it should start its installation. Once it is complete, it should reboot. If it doesn’t, you will have to manually when you are brought back to the CLI.

sudo restart now

If that doesn’t work, we have to start lightdm again;

sudo service lightdm restart

Now, if all has gone well, you should be at the Ubuntu login screen. Reboot through here or log in and then reboot.

You should now not have those pesky monitor signal problems and you should be able to have your proper resolution. Though this only depends if you 1) downloaded the right driver and bit type, set it to executable and 2) installed the driver right. You can change the resolution quickly by opening the terminal and type

xrandr -s ???x???

Changing “???” to your resolution numbers.

The downside to manual installation is that once your kernel updates, you need to reinstall. So always keep your driver in that place and these instructions someplace so you can redo the steps.

OTHERWISE

You will need to addmode new resolutions to fix your monitor size problem.

After you install the drivers from synaptic try running
sudo nvidid-xconfig
If bash doesn’t find this command search for it in /usr/lib/nvidia-current/bin . Of course you should change nvidia-current with the package that you installed like nvidia-current, nvidia-current-updates, nvidia-experimental and so on.

I actually prefer different solution:

  1. Open gnome-control-center (i.e. System Settings).
  2. Go to Software Sources.
  3. Go to tab Additional Drivers
  4. Install the version that you want.
    Just for a note if the version that you want is already installed in Additional Drivers, remove it and then install it from there again.

When you do this remove or backup your current xorg.conf(if exists), because there might be something there that breaks your X in it. I don’t use xorg.conf file at all.

The problem, according to your log, is that the EDID provided by your monitor is invalid because it has an invalid checksum. That either indicates that there’s a problem with the cable connecting the monitor to the GPU or that the monitor is broken.

You can try to work around the problem by telling the driver to ignore the checksum failure by putting the following in /etc/X11/xorg.conf:

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  Option "IgnoreEDIDChecksum" "CRT-1"
EndSection

Please be aware that this could theoretically cause the driver to use a display mode that damages your monitor, so use at your own risk.