Incorrect power management with PRIME configuration

The BIOS update does not fix the problem, I have updated and nothing. With the “cat /sys/bus/pci/devices/0000:01:00.0/power/runtime_status” command it keeps saying that the GPU is suspended but more power is consumed, it gets hotter and the fans turn on.

But it is not that it has never worked for me, with versions 440 of the driver or earlier it worked well, the problem is the later versions of the driver.

From what you say it is understood that it is an MSI problem and they should be the ones who solve it

I suspect with driver 440, runtime pm wasn’t used.

I do not understand what you mean

I think it was working correctly with 440.

When turning on the laptop “Runtime D3 (RTD3) Power Management” kept the GPU suspended, consumption and heating was correct. if I used “PRIME Render Offload” with any application, the GPU was activated and I could use it, once I closed the application “Runtime D3 (RTD3) Power Management” it suspended the GPU again and consumption and heating dropped to the initial.

But I don’t know if we’re talking about the same thing anymore.

We’re talking of the same thing, initial runtime pm support was added in driver 435 but many distros were only enabling it much later. Since you actively checked the runtime pm with 440, my assumption was wrong.
The change introduced in 450 was additionally turning off the video memory so maybe it’s that what your bios doesn’t really support.
So playing with the NVreg_DynamicPowerManagement module option might return it to the behaviour of the 440 driver. i.e. using kernel parameter
and checking
cat /proc/driver/nvidia/./params
that it stuck after reboot.

Yes, that was the problem.

Although I have configured it with
nvidia. NVreg_DynamicPowerManagementVideoMemoryThreshold=0

With this configuration it already works for me as it did with the 440. With “Coarse” the GPU always remained active and had a higher consumption.

I can’t believe it was just this, but as the controller said “Video Memory Off: Supported”, I never got to try.

Thank you so much

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.