Incorrect version of Xcode

I’m attempting to install PGI Community Edition (v18.4) on macOS however I get the following error when selecting the .pkg file:
“The installation requires Xcode version 3.2 or higher”
I recently upgraded to Xcode 10.0. Has anyone else experienced this issue with Xcode 10?

Never-mind. I missed this line in the documentation:
“PGI products are compatible with Apple Xcode 6.4 through 9.x installed.”
I’ll try rolling back my version of Xcode.

Damn. I was having the same problem. I’m not sure I can roll back to a prior Xcode, as I’ve updated Command Line Tools also.

When will PGI support Xcode 10.0?

Hi Alan,

We usually try to get the new Xcodes integrated within a release or two of the PGI compilers after their release. Though since Xcode 10 was just released a little over a week ago, it may be a bit difficult to add it to our October 18.10 release. We’ll try, but more likely it will be in the 19.1 time frame.