Increase receive buffer size

Is there any way to increase the receive buffer size of Jetson TX2? I tried use ethtool but the output showed “Operation not supported”. The command was : sudo ethtool -G eth1 rx 4096
Output: Ring parameters for eth1:
Cannot get device ring settings: Operation not supported

Sorry that our eqos driver does not provide it so ethtool cannot set/get ring parameters.

So it is not possible to change the recieve buffer size by any way?

You may try:

sudo sysctl -w net.core.rmem_max=26214400
1 Like