Infiniband for Mellanox Technologies MT25204

Good day . I need to set up Infiniband on the server where you installed the network card Mellanox Technologies MT25204. To select the operating system there are 2 options : Ubuntu and FreeBSD. Tell me , what OS should be selected ? Which package used to install the service OPENSM, as well as additional tools ? Thanks in advance

Yay! Problem solved . Update the firmware on the adapter and it worked .

But a new problem . Terbium test compound IB protocol between the server and the server on Windows under Linux. Tried to test with the aid of tools and ibv_rc_pingpong ib_write_bw. In both cases, the connection drops with the error message : “Could not read remote address”. Servers are in the same subnet. What could be the problem?

Here is a good starting page:

in the release notes you will also find the supported operating systems and kernel versions.

once you installed the OFED package (which includes the drivers and all tools), you will need to run the opensm daemon to get the network going. start that daemon on one or two servers. all other machines will not need it.

You didn’t mention what is out there beyond the servers. anyways, good luck. we are here!

Good afternoon. Thanks for the info .

I have studied the start page . Install server Ubuntu 14.10. Downloaded MLNX_OFED- Unpacked . Install the needed packages . Run the installation script . Installation failed when trying to “Querying Mellanox devices firmware …”

“Failed to query 0000: 07 : 00.0 device, error: File exists. MFE_OLD_DEVICE_TYPE”

How do I fix this error ? Help please .

typically, benchmarks like ibv_rc_XX may have interoperability issues when working between Windows and Linux. IPoIB should work with no problems.

Thank U! It is. The tests do not work because of the different versions of perftest!

which firmware update version did you use?