Input stream is not processed with probe but runs correctly when more than 1 streams are used

I am working with Dynamic stream adding in T4, Whenever I run it with a single stream it doesn’t work but a new stream is added then all the streams work in the desired way, but again if a stream is removed and only One stream is left in the pipeline then it stops processing again (probe doesn’t produce metadata).

My initial guess: It is attaching to the pad probe but it is unable to receive data from decodebin. Cause it produces messages after few seconds and we can see a frozen frame on the rtsp output as well.

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I was able to solve this issue, In streammux property I was using batch size as total_number or max number of streams. I changed it to 1 and it worked.