Install correct OpenCV for Nano 2gb dev kit

Hey, maybe you can help me.
Few weeks ago i wrote a python script for using my CSI-Camera and uploaded it into my cloud afterwards. Unfortunately, i needed a new setup via SDK manager after my Nano crashed. After installing OpenCV again, i got version 3.2.0 and my script does not work anymore because it does not recognize video/images from my stream. But it is still working in my terminal (nvgstcapture-1.0 worked).

I read that the pre-installed opencv-3.2.0 was built without gstreamer support here:

so i tried to install a new version of OpenCV and here comes the problem.

Anyway, i tried something like that:

where i can not finish it after using make -j4/-j2 or -j1 because there is a make error every time afterwards.

This description i got by trying older versions like 4.5.5 or 4.5.0:

make[2]: *** [bin/opencv_perf_imgproc] Error 1
CMakeFiles/Makefile2:3219: recipe for target ‘modules/imgproc/CMakeFiles/opencv_perf_imgproc.dir/all’ failed
make[1]: *** [modules/imgproc/CMakeFiles/opencv_perf_imgproc.dir/all] Error 2
Makefile:162: recipe for target ‘all’ failed
make: *** [all] Error 2.

Or , where my dphys swap doesn’t change at all and the installation also crashed.

At Iast, i also tried to install openCV 4.6.0 as mentioned here:

but here i got also following error:


I will still search for a solution of my cmake problem but i appreciate any tips and advice to solve that problem.

A user has shared a script for manually building/installing OpenCV:
GitHub - mdegans/nano_build_opencv: Build OpenCV on Nvidia Jetson Nano

Please give it a try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.