Install CUDA 9 on arm64

I cannot install CUDA 9 on my Jetson TX1 (arm64). The repositories provided by NVIDIA are for amd64. I tried adding amd64 as a foreign architecture and did but the problem is that I cannot run the command: sudo apt-get update without errors. I get the following for e.g. :
Err: 7 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted amd64 packages. On http://ports.ubuntu.com/ubuntu-ports/dists/xenial/main the architectures supported are: arm64 armhf … but not amd64. How can I install CUDA 9 on arm64 if the only architecture provided for Ubuntu 16.04 is amd64 ? Thank you !

Hi ybenkhoui, the arm64 version of CUDA Toolkit for Jetson TX1 is downloaded/installed by JetPack. Have you tried flashing your TX1 with JetPack yet?

Note that you download and run JetPack from an Ubuntu 16.04 x86_64 PC, then connect your TX1 to your PC via micro-USB cable and enter your Jetson into Recovery mode by holding down the Recovery button while pressing Reset or Power buttons.

This is exaclty what I did. It is not working. I flashed my Jetson tx1 from my computer using Jetpack (tried 3.0 3.1 and 3.2). When I check if there is a cuda directory I do not find it. Also, when I enter nvcc command it sayd command not found.

Never add amd64 as an architecture to the Jetson. If you added amd64 to the Jetson you should remove it.

armhf/arm32/ARMv7 could in theory be a useful foreign architecture on a Jetson, but reasons for doing so are exceedingly rare.

The host PC can use arm64 as a foreign architecture because it has much cross platform support for building on the PC with the intent of installing to Jetson.

JetPack understands the architecture differences and should show CUDA under both host and Jetson…you could disable install to host and just install to Jetson. CUDA 9 won’t be available on older JetPacks.

The nvcc command is not in your command search path by default even if it is installed. When there you will find it at “/usr/local/cuda/bin/nvcc”. Run JetPack from your host to install CUDA only to the Jetson and it should appear.

Hi,

Do you have any error information when using JetPack?
If yes, could you share the log located in [JetPack_Root]/_installer/logs with us?

Thanks.