Install CUDA 9 on arm64

I cannot install CUDA 9 on my Jetson TX1 (arm64). The repositories provided by NVIDIA are for amd64. I tried adding amd64 as a foreign architecture and did but the problem is that I cannot run the command: sudo apt-get update without errors. I get the following for e.g. :
Err: 7 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted amd64 packages. On http://ports.ubuntu.com/ubuntu-ports/dists/xenial/main the architectures supported are: arm64 armhf … but not amd64. How can I install CUDA 9 on arm64 if the only architecture provided for Ubuntu 16.04 is amd64 ? Thank you !

You should install CUDA on Jetson TX1 using a Jetpack.

Jetpack 3.2 contains CUDA 9:

https://developer.nvidia.com/embedded/jetpack

I flashed my Jetson TX1 more than four times with Jetson 3.2. Whenever I ran the command nvcc-v I get command not found. Also, the cuda directory is nowhere to be found.

The install instructions are here:

https://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/3.2/install.htm%3FTocPath%3D_____3

did you follow those?

For example, at step 14, did you see a dialog which said:

“Push and Install 64Bit CUDA on target”

?

Did you see the “installation has completed successfully” dialog at step 15?

I see that you’ve already posted this question on the TX1 forum. It may be useful to wait for help there.

https://devtalk.nvidia.com/default/topic/1032467/jetson-tx1/cuda-not-getting-installed-when-using-jetpack-3-2/post/5252730/#5252730

You may wish to respond to the action that was given you there.

I followed these instructions. At step 14 I got “Push and Install 64bit CUDA on target”. Once Jetpack got installed on my Jetson TX1 I looked for cuda using nvcc and by looking for its directory but I did not find it. I am trying to work with the ZED SDK and when I am installing it, I get that there is no CUDA detected. I have been having this issue for a week now that is why I am posting and reposting.

Did you provide the log as requested here:

https://devtalk.nvidia.com/default/topic/1032467/jetson-tx1/cuda-not-getting-installed-when-using-jetpack-3-2/post/5252730/#5252730

?