Install CUDA on Geforce 8600GT

Hi,

I tried to install CUDA on my computer with Geforce 8600GT. My system is Ubuntu 12.04
apt-get install nvidia-cuda-toolkit
I can see that CUDA is successfully installed without error message.

My question are:

  1. I don’t know whether CUDA is really installed on my computer.How to check whether it is correctly installed?
  2. how to check which version of CUDA is installed on my computer?
  3. My GPU hardware is old wiht computer compability 1.1, does it support the installed CUDA on my computer?
  4. according to the document on NVIDIA website, I got that the installed lib and files located in /usr/local/cuda, but I cannot find that similiar folder on my computer.

Just now, I tried to execute the following command and get the following error:
sudo dpkg -i cuda-repo-ubuntu1204_6.0-37_i386.deb
sudo apt-get update
sudo apt-get install cuda

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cuda : Depends: cuda-6-0 (= 6.0-37) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

From your first post:

  1. Try:
    1a) which nvcc
    1b) /path_to_nvcc_from_above/nvcc --version
  2. Navigate to the path in 1b, there should be a readme with version contents
  3. New CUDA distributions are backwards compatible, but you won’t gain much benefit since your hardware is so old
  4. 1b should point to where it was installed… if for some reason you still can’t find the compiler location (nvcc), try:
    4a) find / -name ‘nvcc’
    and use that for 1b), etc

If you really want to try out CUDA features, I’d recommend a GT 635: http://www.ebay.com/itm/161206469548 It is a relatively new (and cheap) card for CUDA developemnt/test that is Compute Capability 3.5 capable.

Thanks for your reply.

Yesterday, I tried to remove all Nvidia software by apt-get -remove… and tried apt-get install cuda but not apt-get install nvidia-cuda-toolkit on Ubuntu command console but not GUI environment. Now, if I try nvcc -v, I get the folowing information:
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2013 NVIDIA Corporation
Built on Thu_Mar_13_11:42:14_PDT_2014
Cuda compilation tools, release 6.0, V6.0.1

so I think CUDA is correctly installed on my computer.
Thanks again for your reply.