Install CUDA with a specific driver version

I’m using CUDA together with caffe (http://caffe.berkeleyvision.org/) which unfortunately stopped working with some issue regarding CUDA / cuDNN (https://groups.google.com/forum/#!topic/caffe-users/9vu5f7eJlZ8).

By now I’m quite desperate and grasping at straws here. The only thing I noticed during the many (un)installs is that CUDA is installed with driver version 384. I’m pretty sure that the first time I installed CUDA ist was version 375 and this worked fine as far as I can judge that. I’m installing CUDA via a local deb file but this seems to install the newest driver.

So my question is:

Is it possible to install CUDA with a specific driver version?

My system:

OS: Ubuntu 16.04
GPU: GTX 1080
CUDA: 8.0.61
cuDNN: 6.0.21