Install downgrade Jetpack

Hi, I tried to install Jetpack 4.6 on Jetson Xavier NX.
But SDK manager does not support Jetpack 4.6.

Below is I entered command and result
image

command

sdkmanager --cli --product Jetson --version 4.6.4

What can we do to solve this problem?

Thanks.

As a rule of thumb: The Host OS should match the target OS.

You want to install Ubuntu 18.04 (Jetpack 4) onto Jetson. → You need Ubuntu 18.04 on your Host PC used for flashing.

Hi,
Please check Jetson Nano FAQ

Q: How to install old version JetPack from SDK Manager?

Hi, I tried your advice but got still message

command

1. sdkmanager --archived-versions 4.6.4
2. sdkmanager --archived-versions 4.6
3. sdkmanager --archived-versions

as @fchkjwlsq said, Is Jetpack 4 require Ubuntu 18 on host pc?
But before Jetpack 5 is released, I installed Jetpack 4 using sdkmanager installed on host pc which is Ubuntu 20.

Do I need Ubuntu 18?

Thanks.

The error message in your first post clearly says so: “Error: Product version ‘4.6.4’ is not enabled [ Available on host OS: Ubuntu 16.04, Ubuntu 18.04]”. Maybe they added the version check later after having some problems. So you should stick to my rule of thumb: Target OS version == Host OS version, shrink your PC’s root partition so you can have 18.04 and 20.04 and maybe 22.04 on your PC.

Hi, I installed Ubuntu18, and I checked that I can install Jetpack 4.6

Thanks for your help and Happy new year

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.