Install failure - unmet dependencies

Hello,

Thank you for your suggestions.
I’ve actually searched another forum page and found following advice.
https://devtalk.nvidia.com/default/topic/1004601/jetson-tx2/after-installing-jetpack3-0-host-computer-is-not-able-to-apt-get-update/

What I tried was, as tmx3 suggested, add [arch=amd64,i386] to all deb command in /etc/apt/sources.list.
As a result, my sources.list are as follows.(I have removed all lines starting from # here)

deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial main restricted
deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial universe
deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial-updates universe
deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial multiverse
deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
deb [arch=amd64,i386] http://jp.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb [arch=amd64] http://security.ubuntu.com/ubuntu xenial-security main restricted
deb [arch=amd64] http://security.ubuntu.com/ubuntu xenial-security universe
deb [arch=amd64] http://security.ubuntu.com/ubuntu xenial-security multiverse

Then, I was able to install cuda-toolkid and completed installation to host PC.
After that, following instruction of Jetson, I was able to install to Jetson.

I hope my workaround was able to successfully install Jetpack to Jetson.
But if you notice what I tried may cause another problem, please let me know.
I’ll try again following your suggestions.

I sincerely appreciate your advice.
Thanks.

It should be okay.
Thanks for the feedback.

I have the same issue. When I flash TX2 using either JetPack 3.2 or 3.3, the L4T will be installed without CUDA. I also tried following these lines but it didn’t help, still no CUDA on jetson TX". Any help?

I need to get to work Intel Realsense D435 together with TX2, I flash jetson using JetPack 4.2 but then I couldn’t install librealsense, so I flash jetson using JetPack 3.3 and 3.2, and this time CUDA is not installed on Jetson, so I still cannot install realsense camera. Any help?

Can’t help with Realsense, but do realize that flash itself never installs extra packages (such as CUDA). After flash the TX2 reboots, and only then do the extra packages install. During flash the micro-B USB is used with the Jetson in recovery mode, and ethernet is ignored; following reboot of the Jetson, then the micro-B USB is ignored, and ethernet is used for package additions over ssh/scp. Some later releases use a virtual wired ethernet over USB, but in that case the TX2 is fully booted and not in recovery mode.

You can uncheck flash, and then do only package install at any later date. You could also uncheck package install, and simply flash. The GUI doesn’t always make it obvious since it has a default of both flashing and installing. JetPack releases after 3.3 tend to also complicate things related to networking. Regardless, if the host PC can’t access the internet, or if the host PC cannot access the TX2 via network, then some part of the install will fail. JetPack/SDK Manager 4.2 and up tries to use the virtual wired ethernet on the USB cable. 4.2 and up also relies on you doing a first time boot to create the account used for package install (the ssh login account doesn’t exist on 4.2 until you run first boot with the GUI on the TX2).

Thanks for your comment. I notice that when I flash the TX2 after installing everything in the host machine, on the terminal that runs flashing it shows: Obtaining the IP address of target but never pass this line and never shows the ip address. Do you know what should I do?

For JetPack3.2 and 3.3 the wired ethernet is used. You will need to tell JetPack what the address is.

There are options as to whether your Jetson is connected to a router, versus if connected directly and using the PC as a router. If you log in at the Jetson, and then run “ifconfig” you should see an address for eth0. From your host PC you should be able to ping that address, and if you can ping, then you should also be able to “ssh ubuntu@” or “ssh nvidia@”. If this works, then using that address in JetPack will also work.

How is your Jetson’s ethernet connected? To a router? What is the Jetson’s “ifconfig” output? Can you ping the address of eth0?

Many thanks for your life saving advice! Both jetson and host PC use Wifi. I connected Jetson to Ethernet cable and run JetPack and installation again, again at the end of installation it get stock at obtaing the ip address, I closed that terminal using ctrl c, then got eth0 address from jetson and I could ping that address from host PC, and I could perform ssh… with that address. but still there is no CUDA on jetson. Do I need to install CUDA, Tensorflow… manually? When I used Jetpack 4.2 everything was installed using Jetpack at the first run, is that different in jetpack 3.2 or I still have errors in my installation? Thanks.

Simply connect the wired ethernet, note address as above, and set JetPack to only install software to Jetson and do not flash (recovery mode won’t be used). This will get you to the software install part of JetPack. Flash itself does not install anything “extra”, but by default extra packages are installed after flash completes and the unit is rebooted. Install can start once you can ping or ssh to that address.

JetPack 3.2 and 4.2 are quite different. Logically though, both install software over wired ethernet, but 4.2 makes an attempt at creating a virtual wired ethernet over the micro-B USB. In the later releases, if you use the virtual USB wired ethernet, then the Jetson will have address “192.168.55.1” listed under “ifconfig”. The host PC using the virtual wired ethernet will get an address of “192.168.55.100” (you wouldn’t need the dedicated ethernet port connected for this since the wire would be over USB). Sometimes the host has to be told to allow use of the 192.168.55.100 address; after this, you should be able to “ping 192.168.55.1” from the host.

Another very important change is that on SDK Manager/JetPack4.2 there is no account added to the Jetson by default during a flash. You will need a monitor and keyboard attached to the Jetson during the flash, and then upon first boot you’ll be asked to create an account. Only after the account is created from first boot will exra package install be possible.

Many thanks. When I run the jetpack 3.3 .run file it only passes through flashing the jetson I don’t see any option that I can make it installing software and not flashing. Do I need to run something else? Under Jetpack folder there is an _installer folder but still I cannot run any of files in there.

Many thanks linuxdev.
I finally manage to install CUDA,… I used Ethernet cable to connect both host and Jetson to the same router. After flashing the TX2 the installation stuck at “Obtaining the target ip address” I skip that but ctrl c. Then I run “ifconfig” at jetson and pick the address by the eth0, use that address at host "ping ", ping was succesfull so I at host I run “ssh nvidia@”. The I run jetpack .run from another terminal and at the installation step double click on the “install” icon infront of flash OS and change it to none, and push next, in the next steps I got a new window in which I could write the jetson address (the target address from ifconfig…), and then “nvidia” for both user and password, and afterward the installation of CUDA and other utilities performed succesfully. Hope it helps!