Install Issues on Win7 and some Questions Driver 190.89, Win7, 2x GTX295 finds only 3 GPUs

Hi all,

I’ve some problems here to get our latest GPU assisted server running (we wand to have a look at OpenCL with this one), where you might be able to help.

System:

Windows 7 (64 Bit)

Driver 190.89

Hardware:

2x Zotac GTX295 (Version with 2x DVI ports and no HDMI )

Tyan S7025 @ latest BIOS (1.03a)

2x Intel Xeon E5540 @ 2,53Ghz

32 GB RAM

850W Enermax power supply

Here are my Questions:

[list=1]

VGA Dummies: I’ve read a lot of “you need VGA dummy plugs and extend your display to all monitors” in the net. But all this talk was related to Vista and older drivers. Is this still necessary, or are there software-workarounds out there? I’ve read the buzzwords “DisplayLess Policy” and “LimitVideoPresent Sources”, but got no other information than that it is related to some registry hacks. Can someone shed light on this? If I really need to get dummy plugs: can I buy DVI dummies somewhere? Are there good guides on DIY DVI dummies? Do VGA dummies work with DVI-VGA Adapters?

Onboard graphics and code 43: The machine has an onboard VGA device. I’d like to use this one for primary display and all other GPUs for computing only. Is it possible? So far I’ve not been able to activate the onboard VGA without getting “code 43/device not started” issues in the device manager for several graphic cards afterwards.

BSOD by nvlddmkm.sys: Sometimes when playing a lot with the driver settings I get a BSOD caused by famous “nvlddmkm.sys” the next reboot. Anyway I’ve no clue what causes these BSODs. Any idea how to pinpoint the “kill switch”?

Issues activating multi-GPU mode: The Windows driver allows me to activate a multi-gpu mode. Sometimes (I also did not understand the conditions yet) it just switches back to disabled multi-gpu after a few seconds when enabling it. How can I determine what is causing this issue?

Not all GPUs detected by device query: Anyway sometimes I manage to get all 4 GPUs running in the device manager, and get the multi-gpu enabled. I also enable PhysX and extend the desktop to 4 connected displays (2 displays with 2 inputs each). However when I run the computing SDK the device query examples (both CUDA and OpenCL) report only up to 3 GPUs. I’ve never seen more with all settings I’ve ever tried. How do I get all 4 GPUs detected? Is there a step-by-step checklist or something similar? This problem doesn’t seem to be too uncommon, but I was not able to find a solution working for me.

Remote GPU computing: The machine I’m talking about has many fans and is annoyingly loud. We are used to put “loud” devices to places where we don’t care about sound issues and work with them remotely only. Trying this with GPU computing showed that the native remote desktop connection won’t work anymore, as Windows will not recognise its graphic hardware in such a session correctly. I tried to use VNC and it worked. Is there anything better or another workaround out there?

General: Are there any other pitfalls you want to make sure that I got warned? Do you have any other suggestions or hints to share related to common install issues?

Thanks a lot for your replies. As I seem to have hit many issues other users experienced in similar form on Vista I hope to get both:

Solutions that also work for me and a source of answers for other users running into the same issues when moving to Win7.

Cheers,

Markus

Drivers 191.07 (officially supporting Win7) don’t help. I wonder how much longer it will take to release the next version that I can test…

I have to agree. No Service-Hotline. No Email-Support. Now we all have Windows 7 and have to wait for the next Driver-Version, which we can test again . NVidia wtf? I think we should change to ATI.

I just set up a machine for a new project (Core 2 Quad Q9550, 8GB DDR3, 2x GTX295) running Windows 7, and I’m having the same problem. Only 3 GPUs are recognized. Also, I’m getting some intermittent freezing issues when running any CUDA-enabled apps (the whole OS freezes for ~3 seconds before the program starts running).

I’m running the 191.07 drivers as well. It’s a bit weird, because I originally installed a slightly older driver (one of the 190 versions) which had the freezing problem too, then the 191 version fixed it (temporarily, it seems).