Install JetPack 3.2 Failed "E: fopen failed with file local.db, errno = 2"

I am installing JetPack 3.2 onto TX2. The Component Manager was always empty. I checked JetPack.log under _installer, and it contains the info “E: fopen failed with file local.db, errno = 2”. Could some one help here? Thanks!

Same problem here
Ubuntu 16.04.4 LTS
lsusb returns :
Bus 003 Device 003: ID 0955:7721 NVidia Corp.
I assume that I have successfully entered in recovery mode!
log file :
05-03 17:57:30.0 E: fopen failed with file local.db, errno = 2

Also I was never asked to enter sudo password while installation like I have seen in tutorials.
I have Internet connection too.

Hi

The internet connection is required to properly run JetPack, but not working with static IP address.
There is possibility of a network or internet connectivity problem from your host PC.
Could you help to confirm that and make it automatic DHCP?

Thanks

Yes it is on automatic DHCP. In fact, I am now able to manually download the repository.json file, and then manually download all the packages, which all worked fine. but when I launch the run executable, it failed to install cuda due to some network issue again.

Hi boringboringarsenal,

Could you download JetPack and try again?
If you still got cuda install fail, please provide the logs. Thanks!

I have the same error too, Do you have a solution to this, thanks

被墙了。
在Ubuntu下,设置你的代理,然后用proxychains来代理安装的run文件吧:
proxychians ./JetPack.run

Hi,

I’ve got the same problem. Why does is not work with static IP? Any work-around?

I solved it for me going back to JetPack3.0. That works with static-ip

You might find JetPack3.2.1 works in cases where JetPack3.2 does not (it looks like repository.json reverted to an older version and links break). So if using the exact JetPack version “3.2” this may be an issue.

Hi again,

this is how i got it to work with Jetpack3.2.1. on Jetson TX1.
I used my laptop ubuntu 16.04. with wifi for the installation. (it is still a mystery to me why an ethernet connection is no good)

Then install everything including to the step of flashing the bios of the TX1 by de-selecting the steps afterwards. Then use “ssh-keygen” and “ssh-copy-id” to remove any login request. After that restart the installation and continue with the software installation on target, allowing to manually enter the IP-address.

The method for having the Jetson automatically report its IP address uses wired ethernet. Add to this that DHCP is basically all that’s required for a wired connection, but to use WiFi on a newly flashed Jetson you have to manually intervene (and there is an assumption that by default you’re flashing before adding packages).

Btw, I always set up ssh key access on accounts as well. It’s far less of a nuisance. I even unlock the root account long enough to set up ssh keys for that, then I re-lock root…my host with the right keys can directly run root commands and shells over ssh without sudo. Anyone else trying to log in as root would always fail even if they are at the local keyboard of the Jetson.

Hi linuxdev,

thank you for the hints

I solved it by using vbox:
https://www.findhao.net/easycoding/2376