Install Jetpack in L4T NGC containers

Hi, we want to have a minimum docker image only containing L4T and the corresponding Jetpack. Currently we are trying to do that on top of the L4T Base image here NVIDIA L4T Base | NVIDIA NGC but this image doesn’t contain any apt sources for jetpack and if I run apt update && apt install nvidia-jetpack, it will complain this package not found. Any way to add the apt source into L4T base image? Thanks.

currently we can still use the L4T tensorflow or pytorch image but we don’t need them, all we need are CUDA, CUDNN, TRT, multi media API, gstreamer and DeepStream

What’s the Jetson platform you’re using?


You will need to update the OTA key and apt list first.
For example:

$ wget --no-check-certificate
$ mv jetson-ota-public.asc /etc/apt/trusted.gpg.d/jetson-ota-public.asc
$ chmod 644 /etc/apt/trusted.gpg.d/jetson-ota-public.asc

$ apt update
$ echo "deb r32.7 main" >> /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
$ echo "deb r32.7 main" >> /etc/apt/sources.list.d/nvidia-l4t-apt-source.list

$ apt-get install -y --no-install-recommends ca-certificates
$ apt update
$ apt install nvidia-jetpack

More, we also have a container that building for Deesptream users.
You can also check if this can meet your requirement directly.


1 Like

Jetson NX with host system jetpack 4.6.1

Hi, This is a really good guide and now I can install nvidia-jetpack. But after downloading all the packages, during installation, it raises this error

awk: cannot open /etc/nv_boot_control.conf (No such file or directory)
dpkg: error processing archive /tmp/apt-dpkg-install-xKZU7e/5-nvidia-l4t-core_32.7.1-20220219090344_arm64.deb (--unpack):
 new nvidia-l4t-core package pre-installation script subprocess returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also helpful with the deepStream image, but currently deepstream is still an optional dependency. In the future we may be able to directly use that image but at this moment our deployment is based on TRT mainly. I also tried the L4T tensorrt image but that image, the python version is messed up (it should be python3.6 but it’s python3.8) and thus i met a lot of issues installing common libraries that we need to run our C++ program like boost (boost installing requires some dependency with python3). I also tried to reinstall the python3.8 down to python3.6 but it’s not easy work. More dependency issue is triggered and finally, the container lost control.

I tried copy /etc/nv_boot_control.conf in the host jetson system to the docker container and then rerun the install. But now I get a new error:

dpkg: error processing archive /var/cache/apt/archives/nvidia-l4t-core_32.7.1-20220219090344_arm64.deb (--unpack):
 unable to make backup link of './usr/lib/aarch64-linux-gnu/tegra/' before installing new version: Invalid cross-device link
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I redid my work with the L4T TRT image and i’m able to uninstall the python3.8 and reinstall python 3.6 now. so far i’m good. But i think it’s a bug that’s introduced by the image. May I suggest that for future versions NVIDIA can make sure only necessary changes are included in this image? thanks

I also think to have a L4T-Jetpack image will also be useful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.