Install missing CUDA Toolkit 5.0 Templates Visual Studio 2010?

How do I manually install the CUDA Toolkit 5.0 templates into Visual Studio 2010? The samples compile and run fine. However if I go to [File][New Project] my only options are [Visual C++] [CLR/Win32/General] with 8 Microsoft default options. Nothing related to CUDA. I have been through this guide which implies these templates are automatically installed and doesn’t go into further detail. http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-microsoft-windows/index.html#build-customizations

The files appear to be here but I can not figure out what to do with them. Copying the folders to the 2nd path has not been successful.
C:ProgramDataNVIDIA GPU Computing Toolkitv5.0CudaProjectVsWizardTemplates
C:UsersMyUserDocumentsVisual Studio 2010Templates

I have installed all of these:
Windows 7 Pro. SP1

  1. Visual Studio 2010 Express;
  2. Windows SDK 7.1;
  3. Visual Studio 2010 SP1;
  4. Visual C++ 2010 SP1 Compiler Update for the Windows SDK 7.1 (KB2519277);
  5. NVidia CUDA Toolkit 5.0 (64bit)

Thank You for your assistance!

Bump … Never figured this out. Please Help?

Even if I copy and pastes the ‘template’ project (and rename everything) - it will NOT compile if it is not at the proper depth in the directory tree. Have examined project-properties closely and can not find the solution. CORRECT: “\v5.0…\template.sln”…

FAIL:
\v5.0\mySandbox\drDobbs\drDobbs_vs2010.sln
\v5.0\mySandbox\drDobbs\Lesson1\lesson1.vcxproj
\v5.0\mySandbox\drDobbs\Lesson2\lesson2.vcxproj

Error:
C:/ProgramData/NVIDIA Corporation/CUDA Samples/v5.0/sgp/drDobbs/dobbs-Lesson3/template.cu(28): fatal error C1083: Cannot open include file: ‘helper_cuda.h’: No such file or directory

Here is what I did to avoid fatal error C1083: Cannot open include file: ‘helper_cuda.h’: No such file or directory
Attachments

Right click on your Cuda file (not the soluion or the project).

Select Properties

On the left under Configuration Properties --> CUDA C/C++ --> Common, locate on the right side “Additional Include Directories”

Insert the path of where your CUDA files are. For windows 7, try something like
C:\ProgramData\NVIDIA Corporation\CUDA Samples\v5.0\common\inc

This solved my problem.

Did you ever figure this out? I’m in the same situation

Windows 7 64-bit
Visual Studio C++ Express
CUDA Toolkit 5.0.35

I read a few posts elsewhere and it sounded like installing “Nsight for Visual Studio” would solve the problem, since it has some Visual Studio templates in it. But it requires a real Visual Studio version, not Express.

Do you think that this missing template problem may be a result of using Visual Studio 2010 Express?

Ed

This series of videos(1-3) walks you through exactly this process;

http://www.youtube.com/watch?v=m0nhePeHwFs

Thanks for the videos - that’s a good complement to the udacity course I just started a few weeks ago

If you stop “CUDA Tutorial 2: Basics and a First Kernel” at 9:15 you can see that the presenter doesn’t have those templates either. He sets a Build Customization option, adds to the include path, then adds a library dependency to make it all work. I guess that’s what the template is supposed to do, so I’ll just ape him for now.

Ed

Hi, I solved this problem on my computer just now.

When I compile CUDA Samples(simpleCUBLAS) in Visual Studio 2010, build failed.
fatal error C1083: Cannot open include file: ‘helper_cuda.h’: No such file or directory

I try the solution as Terabite mentioned.However, I can’t find CUDA C/C++.

So, here is my sulution.

Right click on your Cuda file (simpleCUBLAS.cpp) -> General -> Item Type ->
Replace C/C++ compiler with CUDA C/C++.