Install of Tensorflow on TX1

Hi Experts

I am trying to install the wheel version of Tensorflow from Jetsonhack:

When I run

pip3 install tensorflow-1.3.0-cp35-cp35m-linux_aarch64

I get the following error:

pip3: command not found

When I installed python3 I used the following:

sudo apt install python3-pip python3-dev

With no errors.

Any hints,

Thanks sojohans

Hi sojohans,

Not sure your BSP version, but supposed you can find more info from this thread: https://devtalk.nvidia.com/default/topic/1031300/

Thanks

Hi Kayccc

I think the first problem is that pip3 is not installed at all.

When I run:
sudo apt-get -y install python3-pip

I get:

Reading package lists… Done
Building dependency tree
Reading state information… Done
python3-pip is already the newest version (8.1.1-2ubuntu0.4).
The following packages were automatically installed and are no longer required:
apt-clone archdetect-deb dmeventd dmraid dpkg-repack gir1.2-timezonemap-1.0
gir1.2-xkl-1.0 grub-common kpartx kpartx-boot libdebian-installer4
libdevmapper-event1.02.1 libdmraid1.0.0.rc16 liblockfile-bin liblockfile1
liblvm2app2.2 liblvm2cmd2.02 libparted-fs-resize0 libreadline5
lockfile-progs lvm2 os-prober pmount python3-icu python3-pam rdate
ubiquity-casper ubiquity-ubuntu-artwork ubuntu-core-launcher
Use ‘sudo apt autoremove’ to remove them.

But pip3 is not on my tx1…

Any hints?

Thanks,

sojohans

I got it to work by removing pip3 and then re- install.

Hi again

I have now installed Tensorflow and when I run

import tensorflow

I get an error

ImportError: libcudnn.so.6: cannot open shared object file: No such file or directory

Any hints?

I do have a folder cuda-8.0

sojohans

Hi sojohans,

cuDNN can be download and installed via JetPack directly, and seems you’re trying to install it with the latest JetPack now - https://devtalk.nvidia.com/default/topic/1037164/tx1-jetpack-update/

BTW, the VM is not suggested.

Thanks