Install Pytorch after flashing with Jetpack 4.2.2

Hi everyone,

I’ve been trying to install pytorch in one of my TX1’s so I can replicate the process and isntall it in the others (have several, all TX1), but I just can’t find a way to do it.
I’ve encountered several errors, even tried to do it with the source code.
Is there any way, manual or tutorial to do it?

Thanks a lot.

Hi psmosquera, have you tried the pip wheels from this post?

https://devtalk.nvidia.com/default/topic/1049071/jetson-nano/pytorch-for-jetson-nano-version-1-3-0-now-available/

If you get errors from those, can you post them here? Thanks.

Within the sdk manager (to flash the TX1) I have two options:

  1. Install the “Jetson SDK Components” (CUDa, AI Computer Vision, NVIDIA Container Runtime and Multimedia) and end up with 3.4gb of free storage, or
  2. Don’t install “Jetson SDK Components”, end up with 10.4gb of free storage and install CUDA manually.
    Couldnt find a way to install CUDA for TX1’s aarch64, any help with that?

Succesfully installed numpy and torch but having trouble with torchvision

Installation of numpy and torch

nvidia@nvidiaA:~$ pip3 install numpy torch-1.3.0-cp36-cp36m-linux_aarch64.whl

Collecting numpy
  Downloading https://files.pythonhosted.org/packages/b6/d6/be8f975f5322336f62371c9abeb936d592c98c047ad63035f1b38ae08efe/numpy-1.17.3.zip (6.4MB)
    100% |████████████████████████████████| 6.4MB 96kB/s 
Processing ./torch-1.3.0-cp36-cp36m-linux_aarch64.whl
Building wheels for collected packages: numpy
  Running setup.py bdist_wheel for numpy ... done
  Stored in directory: /home/nvidia/.cache/pip/wheels/5e/e9/4b/dd5a8eb53e97dfcc1314eca9c6769edd3cad379d6644c1ad94
Successfully built numpy
Installing collected packages: numpy, torch
Successfully installed numpy-1.17.3 torch-1.3.0

Trouble finding module

nvidia@nvidiaA:~$ cd torchvision
nvidia@nvidiaA:~/torchvision$ sudo python setup.py install
Traceback (most recent call last):
  File "setup.py", line 14, in <module>
    import torch
ImportError: No module named torch
nvidia@nvidiaA:~/torchvision$

Hi,

Could you try it with python3 ?

nvidia@nvidiaA:~/torchvision$ sudo <b>python3</b> setup.py install

Thanks.

Thanks AastaLLL, already found a way, installed some libraries, python3-dev, python3-setuptools, Pillow (for pip and pip3) and finally that setup.py with python3.

But I need help with this:

If you could help me out, it would be awesome,
Thanks a lot.

Hi,

You can find the CUDA package in the download folder.
By default it should be${home}/Downloads/nvidia/sdkm_downloads.

Then, copy the CUDA toolkit into the device and manually dpkg install it.

Thanks.