Install sdk components not working after flash

Hi,
I have a similar issue some others have already asked about, that after having successfully flashed my Jetson Orin NX I am not able to install sdk components via the sdk manager.

I am logged in to the desktop of the jetson device and i am using the same USB-C cable as for flashing, but sdk manager does not recognize any connected device.
Only when I put the jetson device back into revocery mode it becomes detectable by sdk manager or shows up in lsusb, but that does not help.
I configured a static IP address on eth0 of the jetson device (which didn’t have any before) and tried the procedure using that IP address instead of 192.168.55.1, but that didn’t work either.
I tried to ping the static IP from the host machine to no success as well.
I checked dmesg --follow while connecting the USB cable, but nothing showed up there.

The host machine is a native Ubuntu 20.04 install and the firewall is disabled.

Apart from that I am kind of confused by the UI that shows up in sdk manager when trying to install sdk components. It looks different than the one in the documentation (Install Jetson Software with SDK Manager — sdk-manager 2.1.0 documentation).
I am wondering why i can choose between Ethernet and USB for connection, when it seems to be an ethernet connection anyway, as it is necessary to give an IP address also for the USB option.

Some information might help…

During flash the Jetson is always in recovery mode. This turns the Jetson into a custom USB device understood by the custom driver running on the host PC. When flash completes, the Jetson automatically reboots. Most people don’t realize that the system is fully normally booted when it starts installing those optional packages over ssh on the network.

This means you can uncheck flash in JetPack/SDKM, and add packages that are optional, but that these are required:

  • Fully booted Jetson.
  • An admin account that can be logged into via ssh.
  • Networking.

A fully booted Jetson does normally provide a virtual wired USB on the correct USB connector when fully booted. The host PC, within JetPack/SDKM, would use address 192.168.55.1 to access the Jetson for those optional packages. If this is not present, or if the login account is not present, then adding those additional packages would fail. If you have some other networking, e.g., wired ethernet on the LAN, then you could enter that IP address instead, and install packages over that.

Note that on the host PC you could run the command “ifconfig” to see what network devices are present. Perhaps one would have the address 192.168.55.100 (this is what the host PC address would be fore the virtual USB wired networking). On the Jetson the same command would show an interface with address 192.168.55.1 if the virtual network is available.

If the virtual wired is not working, you might monitor “dmesg --follow” on the host PC, and then plug in the USB of the fully booted Jetson to see what log lines occur as a result of plugging in the USB.

As I described initially i tried that and it just shows nothing when plugging in my fully booted Jetson.

In the end I just fetched an ethernet cable and tried the same procedure as above with the same IP addresses and the connection worked and the components are installing now…

Are there special requirements for the USB cable for this procedure? I used USB A to USB C as my host computer has no USB C ports.
For flashing that was no problem at least…

The correct USB-C connector on the Jetson is required. The same one which is used for flash. Other than that there isn’t any special requirement, e.g., adapters from USB-C to USB-A are ok. That and the Jetson has to be fully booted, not in recovery mode.

Any special requirements would fall on the host PC. Sometimes it is as simple as a security feature being on.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.