Install SDK manager via WSL(Windows Subsystem for Linux) for install Jetpack 4.2

I tried to install SDK manager on my WSL(Ubuntu 18.04 LTS).

  1. $ sudo apt update && sudo apt dist-upgrade
  2. Download latest sdk manager installer(sdkmanager_0.9.11-3405_amd64.deb)
  3. put it into wsl filesystem home (~)
  4. $ sudo chmod 777 sdkmanager_0.9.11-3405_amd64.deb
  5. $ sudo apt install ./sdkmanager_0.9.11-3405_amd64.deb
  6. $ sudo apt install libgtk-3-0
  7. $ sdkmanager

Output:
sdkmanager: error while loading shared libraries: libX11-xcb.so.1: cannot open shared object file: No such file or directory

Well, i tried to install ‘libX11*’, but it does not works.

Are there any manual to install sdk manager on virtual environment?

Uhm, i finally find that package "libx11-xcb-dev’ is missing, but now libXss.so.1 is missing…
Are there any dependancy package exist?

libgtk-3-0
libx11-xcb-dev
libxss-dev
libnss3-dev

should be installed.

But now GTK is throwing warning “cannot open display”

(sdkmanager:2271): Gtk-WARNING **: 18:02:23.359: cannot open display:

Ok, I solved it.

  1. Install XMing X Server for windows
  2. $ export DISPLAY=:0 or add export DISPLAY=:0 to the last line of wsl .bashrc file
  3. $ sudo apt install x11-apps
  4. sdkmanager

:)

And this works? Are you able to for instance flash a flash Jetson TX2 with WSL?

Unless WSL is using an ext4 file system I would expect the installation to not work even if it appears to run. Is your WSL using an actual ext4 file system where JetPack runs? The issue is that basically the entire Jetson file system is created based on unpacking some files…and the files must preserve permissions which NTFS is not capable of understanding…the flash would work, but the flashed files would not be valid.

Hi audunnordal,

no, flashing does not work, but installation of packages and programs.

The problem is, that the USB system is not imported in the WSL world, so far.
So you cannot access the jetson in recovery mode.