Install tensorflow on AGX orin based on Jetpack 6

Hi Nvidia:
We are trying to install tensorflow based on Jetpack 6.
Following previous tutorial, we used this command to install tensorflow:

sudo pip3 install --upgrade --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v60dp tensorflow==2.15.0+nv24.04

However, when import tensorflow, the error shown:

2024-05-16 05:33:11.427705: E external/local_xla/xla/stream_executor/cuda/cuda_dnn.cc:9373] Unable to register cuDNN factory: Attempting to register factory for plugin cuDNN when one has already been registered
2024-05-16 05:33:11.427790: E external/local_xla/xla/stream_executor/cuda/cuda_fft.cc:607] Unable to register cuFFT factory: Attempting to register factory for plugin cuFFT when one has already been registered
2024-05-16 05:33:11.429947: E external/local_xla/xla/stream_executor/cuda/cuda_blas.cc:1534] Unable to register cuBLAS factory: Attempting to register factory for plugin cuBLAS when one has already been registered
/usr/lib/python3/dist-packages/scipy/__init__.py:146: UserWarning: A NumPy version >=1.17.3 and <1.25.0 is required for this version of SciPy (detected version 1.26.4
  warnings.warn(f"A NumPy version >={np_minversion} and <{np_maxversion}"

From the URL, it seems like this one is for JP6 DP, not for GA. But I can’t find the package for JP6 GA.

Please help.

Thanks.

Hi,

We have verified the dp package on JetPack 6 GA, it can work correctly.
The message seems not affect the functionality.

Our official package for JetPack 6 GA will be available shortly. (release in monthly manner)
Thanks.

Hi AastaLLL:
Thanks for the reply. We will try it again once the GA is released.
Thank you very much.