Install to recommended versions - trouble w/ TensorRT 7.1 GA

Installing Isaac SDK per instructions - as best I can. Ubuntu 18.04.05, GPU driver 470.42.01, Cuda 10.2.89, Cudnn 8.0.3.33. But when I try next to install TensorRT 7.1.3 (7.1GA) - I get unmet dependencies. Cuda, Cudnn installed with DEB approach. Tried same DEB approach as well with TensorRT.

This is on a clean installation of Ubuntu. Thoughts/ideas?

sudo apt-get install tensorrt
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer-dev (= 7.1.3-1+cuda10.2) but 8.0.1-1+cuda11.3 is to be installed
Depends: libnvinfer-plugin-dev (= 7.1.3-1+cuda10.2) but 8.0.1-1+cuda11.3 is to be installed
Depends: libnvparsers-dev (= 7.1.3-1+cuda10.2) but 8.0.1-1+cuda11.3 is to be installed
Depends: libnvonnxparsers-dev (= 7.1.3-1+cuda10.2) but 8.0.1-1+cuda11.3 is to be installed
Depends: libnvinfer-samples (= 7.1.3-1+cuda10.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

(Here is result of version_checker.py)
aaa

Good/Bad
Good - I managed to get it all installed and working by using TAR installs for TensorRT and Cudnn. Some futzing required.

Bad - Does not support the RTX3070 card. From an Nvidia response in a forum, “You need at least TRT 7.2.1 and CUDA 11.1 to support the 3070”. This is from trying to run the first sample - sampleMNIST for TensorRT. RTX 3070 / TensorRT Internal Error: Assertion failed: Unsupported SM

So I guess I’ll need to play around with upgrading, waiting to see what breaks… :)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.