Installation 2022.1.1 error with Driver 470.141.03

Hello,

I want to install Isaac Sim 2022.1.1 with driver version of 470.141.03 on Ubuntu 20.04. I use the rendering card A40.

However it always shows this error:

Error occurred during installation of Isaac Sim: Command failed: “/home/user/.local/share/ov/pkg/isaac_sim-2022.1.1/omni.isaac.sim.post.install.sh”
X Error of failed request: GLXBadFBConfig
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 0 ()
Serial number of failed request: 188
Current serial number in output stream: 188
2022-09-07 09:45:17 [522ms] [Error] [omni.core.ITypeFactory] ITypeFactory must not be destructed post-main. plugins will not be unloaded.
/home/user/.local/share/ov/pkg/isaac_sim-2022.1.1/omni.isaac.sim.post.install.sh: line 17: 5804 Segmentation fault (core dumped) ${SCRIPT_DIR}/omni.isaac.sim.warmup.sh

Here is the result of nvidia-smi

Can anybody know how to solve it?

Thanks!

BR,
Rosy

Hi. Are you able to run Create or Code from the Launcher?
Please confirm if you have a display plugged into either one of the A40s.
Try running:

xrandr --listproviders

then

xrandr -q

Hi,

I could not run Create or Code successfully.

I connect the display directly to DP port of A40, but it can not display anything, showing no signal. But it can show some results when connecting VGA port of server. Here are the results when connecting to VGA port of server.

While connected to the server VGA port, try reinstalling the NVIDIA Drivers using the .run installer. Try the 510.x drivers too. Disable any nouveau drivers.
Next connect the display to the A40 displayport to run the Omniverse apps.

OK. Will try it.

Just want to confirm, running Omniverse apps on the server with A40 does not involve virtual GPUs, such as the server provider license stuff, right?

Yes. I believe so. You don’t need vGPU to run Omniverse apps. Should be able to use the A40 as a bare-metal GPU.
Are you running Ubuntu as bare-metal too?

still not working. Yeah, we runs GPU and Ubuntu as bare-metal.

Below is the log. Hope it can help.
gpu-displaymodeselector-gpumode.txt (7.3 KB)

I’m not familiar with the displaymodeselector tool but how about trying the “physical_display_enabled_8GB_bar1” mode too?
Please share a copy of the full Isaac Sim log when running the post-install during the Launcher install. There could be other clues in there.
Please also try any latest drivers, even the 515 drivers.