Installation error - Jetpack 4.2.2 on Jetson TX1

Hello everyone,

From a few days ago, I am trying to update my Jetson TX1, formerly on Jetpack 3.3.

I downloaded the SDKManager tool from Nvidia, and I followed all the installation steps. I had no issue at all performing the host installation (CUDA, OpenCV, etc.). On the same way, I could install the Jetpack 4.2.2 firmware on the TX1 (there were no error messages on the terminal screen inside the SDK Manager).

However, when the board is switched on in order to complete the installation (and assign an IP in order to finish the board installation via SSH), I receive this message on the systemd serial console:

Host read timeout at address 5458045c
Please complete system configuration setup on /dev/ttyGS0 to proceed...
A start job is running for End-user configuration after initial OEM installation (Debconf UI) (7min 55s / no limit)

This message shows forever, and I can’t find a similar issue on the forums (so sorry if it is duplicated). I found a couple of likely threads where the solution was just to switch to another terminal (/dev/tty_), but I am not able to do that, as I get the same message on every login shell that I try to access to.

Can anybody help me? Thanks a lot in advance.

I’ve tried several times to perform the installation again, coming back to JP 3.3 previously, but it’s always the same ending. I can’t install JP 4.2.1 neither.

Could you try to reboot device once you hit that error? Does it resolve?

Hello Wayne,

No, I forgot to mention it, but rebooting the board drives me to the same error on the serial screen.

Hi ironkidnacho,

After flash finished, are you compete the init setup process? setup the username, password, timezone…etc.
Please connect the HDMI monitor and complete the setup, then start install SDK components.
Thanks!

Hello,

That is what I mean: when I connect the HDMI monitor in order to complete the setup as you said is when I get this error.

Hi ironkidnacho,

Could you try flash by manually?

cd /home/<username>/nvidia/nvidia_sdk/JetPack-4.2.2_Linux_GA_P2180/Linux_for_Tegra
sudo ./flash jetson-tx1 mmcblk0p1

Could you also share your full log?

I see another error “Host read timeout at address 5458045c” in your log which looks abnormal.

Hello, thanks for both replies.

When I try a manual installation, it freezes while flashing the system.img, as can be seen on the attached log.

https://pastebin.com/u9tXdvDL

With respect to the requested full log, it is shown in the display attached to the Jetson, so I can’t copy it. However, it is a few lines, with not so much more relevant that those lines I mentioned.

Thanks again.

Hi,

It seems pastebin has been blocked. Could you use attach or google drive to share the log?

As for the log, usually we use the UART console to dump log but not read from monitor directly.

There are also similar topic but they resolved it by press the reset button too.
https://devtalk.nvidia.com/default/topic/1058006/jetpack-4-2-1-fails-to-boot-on-nano/

Hello everyone,

After struggling with this, I stuck on JetPack 3.3. However, I tried again two days ago, installing the newest release. I obtained the same message, but this time rebooting the board solved it flawlessly.

Thanks a lot for your help, I hope this is useful for anyone. Kind regards!

I got the same issue where the setup stopped at (Debconf UI) after about 8 to 10 minutes into the installation, and it was consistent even though I rebuild the SD Card like 4 times. The Jetson Nano was connected to a TV via a video switcher, and notice that it showed an error detecting the EDID in the beginning, so I connected it directly to the TV, and worked without any issues on the next rebuild. Problem fixed.

1 Like