Installation error ros 2 in JetPack 5.1.1

I am trying to install ros2 foxy in JetPack 5.1.1 on Jetson Orin NX. But I just keep having unmet dependencies error when I try to install ros-foxy-desktop.
I checked rep 2000 and seems foxy is available in ubuntu 20.04 (focal).

Your advice would be appreciated.
Thanks,

You can run various distributions of ROS/ROS2 on any Jetson device through these containers:

You can also run Isaac ROS:

Thank you!
I am just curious but does Jetson Orin NX supports CUDA?

Sure, JetPack 5.1.2 includes CUDA 11.4.19
You can refer to JetPack SDK 5.1.1 | NVIDIA Developer

I am having problem while installing libopencv-dev having unmet dependency error.
Is there any settings I should know or any suggestions for it?
I appreciate for your supports

Let’s track your libopencv-dev installing issue at Error while instaling libopencv-dev provided in jetpack 5.1.1 repo - Jetson & Embedded Systems / Jetson Orin NX - NVIDIA Developer Forums

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.