Installation Error With CUDA Toolkit 4.0.17

Every time I execute the package cudatoolkit_4.0.17_macos.pkg, I get an installation error while it is trying to write files. I don’t know what else I can try, and I don’t know what other information I can give.

As per guidelines in ManuelG’s profile:

NVIDIA GPU model: GeForce 9400M
Display driver version: I installed the NVIDIA CUDA 4.0 FOR MAC RELEASE
OS: Mac OS X Version 10.6.7
CPU: 2.4 GHz Intel Core 2 Duo
Memory: 2* 2GB DDR3 1067 MHz
Motherboard: Not sure
Laptop make and model: 2009 13 inch Macbook

Problem solved: I had a corrupted download. After the 10th try, it finally worked. Now trying to resolve other issues.