installation fail of CUDNN with RTX 2070 SUPER

I bought rtx2070 super yesterday, tried to install cudnn, it has been fail.

Also, cudnn example code is not work with error.

Is anyone success the installation?
If so, can you tell which version is successed?

my environment:

OS : ubuntu 16.04.6
driver : 430.34 & 430.50(tried both)
cuda toolkit : 10.1
cudnn : v7.6.4 (September 27, 2019), for CUDA 10.1

Ubuntu 16.04 is broken in terms of newer nvidia drivers. Uninstall/purge anything nvidia/cuda you installed, upgrade to 18.04, install the driver through ubuntu’s software&updates application, then download and add the cuda .deb but don’t run sudo apt install cuda, instead run
sudo apt install cuda-toolkit-10-1
and add the needed paths.
Then add the machine learning repo and install cudnn.

I have been passed the sudo apt install nvidia-cuda-toolkit.

nvidia-sim
±----------------------------------------------------------------------------+
| NVIDIA-SMI 430.50 Driver Version: 430.50 CUDA Version: 10.1 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce RTX 207… Off | 00000000:07:00.0 On | N/A |
| 24% 31C P8 15W / 215W | 326MiB / 7981MiB | 1% Default |
±------------------------------±---------------------±---------------------+

nvcc -V is show as follow:
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

But I can’t find the path “/usr/local/cuda” to add path PATH on .bashrc

So, I searched with “find / -type d -name cuda 2>/dev/null”
/usr/include/thrust/system/cuda
/usr/lib/cuda

How can I have next step? and, installation of cudnn is unnecessary?

thanks.