Installation Failed using USB for Flahing

Right now I am using USB 30GB for flashing purpose for initial setup of Jetson Orin Nano using SDK Manager. The downloading completes and the Installation reaches to 50% and Flashing reaches to 99% when the following Installation failed error came.
Flash Jetson Linux: flash-command terminated with error
I tried twice but the same error occurs at 50% installation. Why is it so? even the SDK manager supports USB device for flashing but still error occurs.
Is the error occurs due to space limitation of USB (which is 30GB)?.

Please put the log here.
By default we only support 64GB or larger storage devices.

Regarding space, know that on the host PC that an image is created which is the size of the full partition on the Jetson (that’s the “raw” image). Then a “sparse” image is created, which is essentially the same image without the “empty” parts of the filesystem (as the filesystem fills up the size of the sparse image approaches the size of the raw image). This is in addition to a lot of other content, e.g., boot partitions and various binary content. If you are flashing a 30 GB image which is 75% full, then you need (just for the main image) “30+0.75(30) GB = 52.5 GB”.

The SD card models have a lot of binary content which is for flash and the equivalent of a BIOS and this goes into QSPI memory, and that too takes space (but it preexists, it isn’t generated; installation of the flash content also takes space).

Also, if you use a VM, expect USB to fail unless you’ve correctly set up the disconnect/reconnect (which is a VM topic which cannot be handled by the flash software).