Installation of cuda 11.0 fails on Lenovo thinkpad P15 ubuntu 20.04

Hi,

I am working on a “fresh” vanilla ubuntu 20.04 installation (nvidia drivers not installed). Graphic cards: Quadro RTX 4000 Mobile / Max-Q

I would like to install cuda 11.0 (not a newer version as I will use it for tensor flow: Build from source  |  TensorFlow)

How I am attempting to install:

wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/cuda-ubuntu2004.pin
sudo mv cuda-ubuntu2004.pin /etc/apt/preferences.d/cuda-repository-pin-600
wget http://developer.download.nvidia.com/compute/cuda/11.0.2/local_installers/cuda-repo-ubuntu2004-11-0-local_11.0.2-450.51.05-1_amd64.deb
sudo dpkg -i cuda-repo-ubuntu2004-11-0-local_11.0.2-450.51.05-1_amd64.deb
sudo apt-key add /var/cuda-repo-ubuntu2004-11-0-local/7fa2af80.pub
sudo apt-get update
sudo apt install cuda-11-0

the error:

INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Loading new nvidia-450.51.05 DKMS files…
Building for 5.8.0-43-generic
Building for architecture x86_64
Building initial module for 5.8.0-43-generic
Error! Bad return status for module build on kernel: 5.8.0-43-generic (x86_64)
Consult /var/lib/dkms/nvidia/450.51.05/build/make.log for more information.
dpkg: error processing package nvidia-dkms-450 (–configure):
installed nvidia-dkms-450 package post-installation script subprocess returned error exit status 10
Setting up mesa-vdpau-drivers:amd64 (20.2.6-0ubuntu0.20.04.1) …
dpkg: dependency problems prevent configuration of nvidia-driver-450:
nvidia-driver-450 depends on nvidia-dkms-450 (= 450.51.05-0ubuntu1); however:
Package nvidia-dkms-450 is not configured yet.

Any help would be welcome

2 Likes