Installation of flash jetson tx2 is taking longer than expected on jetpack 4.6.4

when i tried to install flash jetson tx2 using sdkmanager jetpack 4.6.4. it is showing the message as it is taking longer than expected. i am using ubuntu 18.04 and i tried different USB which are having data transfer capacity. but i am getting the same result. it always stopping at the 41.58% of flashing


there is a export logs button on sdkmanager. Pause the flash and dump the log.

It may tell what is going on.

i am attaching the log file please help me (154.3 KB)


Not much clue from the host side log.

If this is NV devkit, please follow this page to dump the flash log from device side.

png2pdf.pdf (247.0 KB)
Iam attaching the screenshoot of my error log. Please help me
Thanks in advance

we connected jetson tx2 to ubuntu 18.04 using usb to ttl serial cable and configured using minicom but when we are trying to flash using sdk manager it’s showing device not detected.
when we checked with lsusb we got “Bus 001 Device 017: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port”. We also tried with recovery mode but there is no detection of device.


usb-ttl cable would not /should not affect the detection of recover ymode.

You can try more times because you can still detect the board in recovery hours ago.

BTW, it is actually weird that you said “We also tried with recovery mode”. The board has to be in recovery mode to get flashed no matter what… You don’t need to explicitly say “oh I also put the board into recovery mode before flash”. It is kind of common sense. No need to highlight.

If you didn’t put the board into recovery mode before, then I guess you don’t put it correctly.

Incidentally, a log showing lsusb of the PL2303 device won’t be related to flash (this monitors but does not participate in flash; any host PC indication of this port is not a modifier of flash). I assume this is on the host PC side since you are flashing? The serial console port, at the USB end, is in no way an indicator of the Jetson. If you are saying that there was no output to the serial console port when the PL2303 was detected, then it might just mean a difference in port settings. Default is 115200 8N1 (no CTS/RTS). If you have an oscilloscope, then you could monitor RX and TX to see if the UART end has activity (and this does have a bearing on whether or not the Jetson is running).

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.