Installation of Nsight Systems on Jetson TX2

Hi there,

I want to install nsight-systems to Jetson TX2 (t186). My jetpack version on target device is 4.4. I was trying to install the deb package from Nvidia Jetson Repo, but the repo does not contain the package for mentioned target device with mentioned jetpack version.

Where can I find the nsight-systems package for TX2 that uses Jetpack 4.4?

P.S Tried to install through SDK Manager as well, but still no success. “” version does not support Jetpack versions older than 4.6.2.

P.S.S Tried SDK Manager version “” too. It shows the following problems:

Failed to load server data.
Failed to get configuration file from the server. Please check your network connectivity.

I am sure there is no problem with my network connection. I checked with other version of SDK Manager image at the same time and its connection works okay. The SDK Manager Docker image must be problematic.

SDK Manager Archieve


The package is in the x86_64/xxx sections.
JetPack 4.4 is compatible with Nsight System 2020.2.
Only the x86 package for remote profiling is available.


Thanks for the response. Yes, I saw the package under x86_64 section, but my architecture is arm 64. So I cannot use nsight systems for profiling my TX2 with Jetpack 4.4, can I?


You will need an Ubuntu x64 platform to remote profile the app on TX2.
Or you can try nvprof which is available on the Jetson directly.

$ /usr/local/cuda-10.2/bin/nvprof --help


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.