Installation of other OS via USB

Been playing with a Jetson AGX Orin, have it able to boot EFI images from USB, all good. GRUB menu of Linux distros I have tried appears (Fedora, Rocky, even Ubuntu). However, once out of the EFI stub (last message printed is “Exiting boot services…”) nothing is printed to screen (it goes to sleep), a couple of unprintable characters are shown in serial console and then “lockup”.

I have tried to alter settings that would seem to make sense to alter and tried again (e.g., ACPI / DevTree), etc. but no luck. Should note that in DevTree, there are extra messages about the additional CPUs 1-x, but in ACPI there are not. I expect that ACPI would be the proper setting in this case.

I expect that I should be able to at least boot these OSes on (Fedora 37 Arm, Rocky 8.6 Arm, Rocky 9.1 Arm, Ubuntu Server 20.04 Arm) the Jetson, even if installing may have other nits. I have tried to run text install / basic graphics, setting console=tty0 on grub command line, no changes.

Any pointers to this? Someone mentioned they got Windows for Arm to boot / install, so it seems possible. Feeling pretty dumb right now.

Thanks in advance.

Anyone have any suggestions? Questions that get no response seem to either mean that it’s a hard question or that I’m really asking a dumb question. In this case it would be helpful even if I knew which it was.


Please refer to the section in developer guide:
Root File System — Jetson Linux Developer Guide documentation

You can run Minimal Flavor Root File System first, and develop your own rootfs based on it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.