Installation of TADP failed on Windows 7 and Ubuntu 12.04 64bit

I tried installing TADP 3.0r4. On Windows 7 I got the error message similar to a previous post https://devtalk.nvidia.com/default/topic/811800/android-development/tadp-installation-failure-in-both-win7-and-win8/.

I’m more interested in the TADP version for Linux 64bit since it has CUDA. On Ubuntu 12.04 64bit when I install it, I got an error saying that the file /.NVIDIA/TADP/007/android-ndk-r10c-linux-x86_64.bin is not found.

I checked that location and the file is actually there, with execution permission. However when I manually try to run it in a terminal it still says found is not found. After doing some google search I found this post explaining the issue:
http://askubuntu.com/questions/133389/no-such-file-or-directory-but-the-file-exists/133460#133460

Basically it says that running a 32-bit binary on a 64bit platform will fail.

I tried what the post said to verify the property of the file by using the “file” command. It shows the following:

$ file android-ndk-r10c-linux-x86_64.bin
android-ndk-r10c-linux-x86_64.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0x13b76de68ec17f30e2e19d37f8b379fc204107af, stripped

So it seems that the file is indeed a 32bit executable. Is this the issue and how do I resolve this?

By following one of the answers in the post I linked and run the two commands below I was able to successfully install TADP on Ubuntu 12.04 64bit.

sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386