Installation problem

Recently I bought a labtop and it has Geforce 8600M GT graphics card.
I confirmed that this graphics card is included in the list of CUDA-enabled products, and tried to install CUDA.
First, I tried to install "
NVIDIA Driver for Microsoft Windows XP with CUDA Support (177.35)", but it showed an error message like “The NVIDIA setup program could not locate any drivers that are compatible with your current hardware. Setup will now exit.”
So I gave up to install driver and installed CUDA toolkit and SDK.
After installation, I executed one example in the project folder. But it didn’t work in device mode.
The error message is “feature is not yet implemented”.

I think it is because of the failure of installing CUDA driver.
But I don’t know why the driver can’t be installed.
My OS is windows xp 32bit so I downloaded windows XP version driver (not the version of window xp 64bit).
Also I’m sure that I installed toolkit first and then installed SDK.
And I have installed proper graphics card driver. (There is no device conflict)
If you know the reason of this problem, please let me know.
Thanks in advance!

p.s. I also tried to install updated driver posted just below. But it doesn’t work, either.

I’m having the same problem but using a 8800GT latest driver according to NVIDIA website.