Installation problems on SUSE 10.2

Hi,
I carefully read the installation and release notes before trying to install PGI workstation (as a trial).

The installation seemed to go smoothly, but when I tried to follow Step 6 in the installation notes by typing “pgf77 -V x.f” I got the message

pfg77-Error-please run makelocalrc to complete your installation

I couldn’t find any description of makelocalrc in any of your documentation, but when I found makelocalrc, I created the example path
/usr/pgi/linux86/6.2

then I ran the example command

/opt/pgi/linux86-64/6.2/bin/makelocalrc -x /usr/pgi/linux86/6.2


the following error message came back:

unknown glibc version (2.5)

Do you have any suggestions?? I’ve looked through the documentation, the FAQs, and the forums.

Hi Drunkle,

SuSE 10.2 will be supported in the 7.0 release due out shortly. Please refer to our FAQ pages for a complete list of supported operating systems.

Thanks,
Mat

Hello Drunkle,

according to https://www.pgroup.com/support/new_rel.htm#bug there seems to be a problem with glib 2.5 and PGI release 6.2.

There is a patch available at: https://www.pgroup.com/support/makelocalrc_fc6

Just replace /yourdownloaddirectory/pgi/linux86/6.2/bin/makelocalrc and /yourdownloaddirectory/pgi/linux86-64/6.2/bin/makelocalrc with the patchfile. Then execute the install script.

Best Regards
Markus Roeffen

Hi Mat,

I’m also running Suse 10.2 and need a F90 compiler. Can you estimate when version 7.0 will be released?

Thanks,
Doug


Hi Doug,

Actually, 7.0 was just released yesterday. We won’t formally announced that it’s out until next week, but you can download it from the PGI Downloads page.

Note that we have also issued a patch which will allow 6.2-5 to install properly on SuSE 10.2 and Fedora 6. Please see our FAQ page for more details.

Thanks,
Mat

[/url]