Installing Blas-Lapack-Lapacke in Visual Studio 2017 in a CUDA project

I’m currently having an annoying time trying to setup my PC to run Blas, Lapack and/or Lapacke. All the tutorials are old or at some point just vague or give me errors.

I’m really new (1 week tops) at this Visual Studio, CUDA, C++, and compiler things and I can’t get this right.

I’m running Visual Studio 2017 on a 64-bit Windows 10 machine and I need to run Lapack lib to solve some matrix calculation. The bottom line is, I tried some tutorials and follow some steps, but to no luck.

I’m trying to work my way through C++ before implementing cuSOLVER or something, but I’m not progressing.

I tried compiling with Cmake and using precompiled libs and dlls, all came out with some error. The last one I tried was compiling lapack-3.7.1 (because 3.8.0 didn’t even finish the Cmake process) in my machine and running the ALL_BUILD, INSTALL and RUN_TESTS. The ALL_BUILD went fine, or at least it seems that way, but the Install process just failed with this error.

Severity Code Description Project File Line Suppression State
Error MSB3073 The command “setlocal “C:\Program
Files\CMake\bin\cmake.exe” -DBUILD_TYPE=Debug -P cmake_install.cmake
if %errorlevel% neq 0 goto :cmEnd :cmEnd endlocal & call :cmErrorLevel
%errorlevel% & goto :cmDone :cmErrorLevel exit /b %1 :cmDone if
%errorlevel% neq 0 goto :VCEnd :VCEnd” exited with code

  1. INSTALL C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets 133

I’m using this step-by-step at the time. But the text is a bit out of date with the version.

As I said, I’m too new at this that it can be simple enough that I don’t get it.

This doesn’t have anything to do with CUDA.